zurück zur
HILFE


Plus-Version

Geograf-Import
ALK-Import
Bitmaps
Bedingungsgenerierung
Doppelte Punkte suchen
WLDGE-Import
Digitalisierung erzeugen
Punktraster erzeugen
Lagegenauigkeitsstufe erzeugen
WMS
KafPlotService
Punkte umnummerieren
Katasternachweis umgewichten

Geograf-Import

Die über die Geograf-Out-Schnittstelle ausgelesene Datei kann mit KafDat importiert werden, die DAT-Datei wird dabei mit Daten der Geograf-Out aufgefüllt. Auch mit KafPlot kann die Geograf-Out importiert werden, die Daten werden sofort in der Grafik angezeigt.

Folgende Daten werden aus dem Geograf-Projekt übernommen:

Punktdaten:

Aus dem Geograf-Projekt werden die Punktdaten vollständig übernommen. Die Geograf-Lageklasse entscheidet über den Status des Kafka-Punktes:
Geograf-LageklasseKafka-Punktstatus
Fest 1Fest
Gerechnet 2Beweglich
Digitalisiert0Näherung
Ungültig 5Fehlerhaft
Soweit die Geograf-Punktarten OSKA-konform sind, werden diese nach KafPlot übernommen. So erhält zum Beispiel ein Punkt mit der Punktart 0118 in KafPlot auch den Oska 0118, automatisch wird der Punkt mit Art 2 und Ebene 1 erzeugt.

Digitalisiersysteme:

Die Digitalisierung aus Geograf wird mit KafPlot in Transformationsblöcke übertragen. Die Transformationsblöcke behalten dabei die Systemnummer und die Anzahl der Transformationsparameter. Die Gewichtung der einzelnen Systeme sollten im Editor bearbeitet werden.

Bedingungen:

Ebenfalls vollständig übernommen werden die Bedingungen, die in Geograf entweder automatisch bei der Digitalisierung erzeugt oder manuell eingegeben wurden. Mit der Verbindung Geograf-Kafka, die hier mit KafPlot geschaffen wurde, steht für die Homogenisierung ein wesentlich leistungsfähigeres Werkzeug zur Verfügung. Schließlich können zusätzlich zu Digitalisierungen und Bedingungen auch Messwerte verarbeitet werden.

Objekte:

Um nach KafPlot Grafikdaten übertragen zu können, ist es notwendig, in Geograf ebenfalls objektstrukturiert zu arbeiten. Soweit die Daten ALK-konform (OSKA Brandenburg) verschlüsselt sind, ist die Schnittstelle in der Lage, die vollständige KafPlot-Struktur aufzubauen.
Die Flurstücke werden mit ihrem Flurstückskennzeichen und dem zugehörigen Umring gespeichert. Dabei werden die Nutzungsartenobjekte aus der Folie 21 korrekt dem jeweiligem Flurstück zugeordnet. Besondere Ausgestaltung, wie Flurstückskennzeichen mit abweichender Objektkoordinate oder Nutzungsartensymbole werden in die KafPlot-Datenstruktur übernommen.
Gebäude, soweit ALK-konform verschlüsselt, werden ebenfalls übernommen. Die Objekte erhalten analog zur ALK einen Gebäudeschlüssel. Besondere Ausgestaltungen, Symbole oder Texte werden gespeichert.
Analog wird mit sonstigen Objekten verfahren, sie werden Topographieobjekte. Die Objektschlüssel aus Geograf, soweit ALK-konform, werden übernommen.

Fehlerbehandlung:

Beim Importieren wird die Fehlerdatei <auftrag>.Import.err erzeugt, in der eventuell aufgetretene Fehler dokumentiert werden. Diese Fehlerdatei kann in KafPlot importiert werden, die fehlerhaften Objekte werden dann markiert dargestellt und die Meldungen an der fehlerverursachenden Stelle angezeigt.

ALK-Import

Es setzt sich endlich durch, daß die Katasterämter mit den Messungsvorbereitungen auch die ALK in digitaler Form liefern. Mit dem ALK-EDBS-Reader ist es möglich, diese Daten direkt nach KafPlot und somit in die Auftragsdatei zu importieren. Damit verkürzt sich der bisher notwendige Umweg über Geograf.

Punkte ohne amtlichem Kennzeichen werden in der EDBS-Datei ohne Punktnummer übertragen. Beim Import vergibt KafPlot eine lokale Punktnummer. In der KafPlot.properties kann die Startnummer für die umzunummerierenden Punkte vorgegeben werden:

   # ALK-Import
   AlkReader.newNumber = 100001

Die EDBS-Datei ist in die Grafik zu importieren. Die Übernahme der Daten in Auftragsdatei erfolgt dann mit dem Speichern der Grafik. Der ALK-Edbs-Reader versucht so viel wie möglich an Daten zu übernehmen und startet im Notfall Reparaturversuche. Aufgrund der sehr unterschiedlich strukturierten Edbs-Dateien der einzelnen Katasterämter (obwohl im Vermessungswesen des Landes Brandenburg eine einheitliche IT-Landschaft durchgesetzt wurde), werden beim Import der Daten sicher immer wieder Fehler auftauchen. Diese werden nach dem Import als Fehlermeldungen angezeigt und auch in einer Fehlerdatei (import.err) abgelegt.

Bitmaps

Mit der KafPlot-Plus-Version steht dem Anwender ein Bitmap-Modul zur Verfügung. Es erlaubt dem Anwender die gebräuchlichsten Bitmap-Dateiformate zu laden, einzupassen und die Anzeige zu manipulieren.

Geladen werden Bitmaps mit dem Befehl Extras > Bild laden. Soweit die Bitmap bereit georeferenziert ist, also eine Datei *.tfw, *.jfw oder *.gfw vorliegt, wird diese Georeferenzierung von KafPlot automatisch geladen. Damit das Bild angezeigt wird, muss in der Symbolleiste die Darstellung der Bilder eingeschalten sein. Es können beliebig viele Bilder geladen werden, Grenzen setzt hier nur der Arbeitsspeicher Ihres Rechners.

Einstellungen

Einstellungen zu den Bitmaps werden unter Ansicht > Optionen > Sonstiges vorgenommen. Damit die Bilder angezeigt werden, muss der Schalter Images gesetzt sein.
Der Schalter Rahmen ermöglicht es, um das Bild einen Rahmen in der Grafik darzustellen. Mit dem Schalter Bild kann das Bild ein- oder ausgeblendet werden. Zusätzlich kann mit dem Schalter Name auch ebendieser dargestellt werden.

Mit dem Schalter ... öffnet sich ein weiteres Dialogfenster.

In dem Dialog sind alle geladenen Images aufgelistet. Sie können einzeln, oder mit den Schaltern Alle oder Keine an- bzw. ausgeschalten werden. Der Schalter Löschen entfernt die markierten Bitmaps aus der KafPlot-Grafik, die Dateien auf der Festplatte bleiben natürlich erhalten. Mit Übernehmen werden die gemachten Einstellungen gespeichert und die Grafik neu gezeichnet.
Soweit ein einzelnes Bild markiert ist, kann mit den Schaltern nach oben bzw. nach unten die Bildreihenfolge geändert werden.
Der Schalter Optionen führt in den Optionen-Dialog für das markierte Bild. Hier finden sich alle Einstellungen bezüglich der Darstellung des Bildes und seiner Georeferenzierung.

Darstellung

Mit dem Schiebeschalter Transparenz kann die Durchleuchtung des Bildes eingestellt werden. Dazu gibt es zwei Varianten:
normal: Das Bild wird gleichmäßig durchleuchtet. Einstellungen im positiven Bereich steigert die Transparenz des Bildes, bei 100% ist es vollständig durchleuchtet, d.h. nicht mehr sichtbar. In einigen Bildformaten können Informationen über die Transparenz der Bildpunbkte gespeichert werden (Alpha-Kanal). Diese Tranzparenz kann gemindert werden, indem der Schiebeschalter in den negativen Bereich verschoben wird.
vollständig durchleuchten: Es werden Bildbereiche vollständig ausgeblendet. Einstellungen lassen helle Bildbereiche durchscheinen, je höher die Einstellung gewählt wird, desto mehr Farben werden ausgeblendet. Diese Variante bietet sich besonders für Katasterkarten an, die hellen Flächen werden durchleuchtet während die Strichzeichnung scharf sichtbar bleibt.

Mit dem Schiebeschalter Helligkeit wird die Helligkeit des gesamten Farbspektrums verändert. Der Schalter Kontrast verstärkt die dunklen Farben und hellt helle Bereiche auf. Die Konturen des Bildes wird mit dem Schärfe-Regler verändert. Negative Einstellungen lassen das Bild weicher erscheinen, positive Einstellungen schärfen die Konturen. Mit dem Schalter Farbe werden die invertierten Grauwerte des Bildes eingefärbt.

Die obigen Einstellungen verändern nur die Anzeige des Bildes, die gespeicherten Bilddaten bleiben original erhalten.

Georeferenzierung

Jedes eingelesene Bild kann einzeln georeferenziert werden. Pro Bild werden die Koordinaten der linken oberen Bildecke, ein Maßstab und eine Rotation gespeichert. Die Georeferenzierung kann über drei verschiedene Wege eingegeben werden:

Bereits georeferenzierte Bilder haben die Transformationsparameter in einer *.tfw (oder auch *.gfw, *.jfw ...) - Datei gespeichert. KafPlot liest diese Datei, soweit vorhanden, beim Bildladen mit. Das Bild wird dann sofort an der korrekten Stelle wiedergegeben.

Nicht referenzierte Bilder können grob mit dem Schalter Verschieben positioniert und mit dem Schalter Größe ändern in ihrer Größe verändert werden.

Als zweite Möglichkeit können die Transformationsparameter in dem Dialog Imageoptionen > Eingabe eingegeben werden.

Es ist aber auch möglich, die Transformation über Passpunkte herzustellen. Die Passpunkteingabe wird mit dem Schalter Hinzufügen im Imageoptionen-Dialog gestartet. Nacheinander werden Bild- und Passpunkt abgefahren, beachten Sie die Angaben in der Statusleiste. Sollte während der Passpunktwahl ein Zoomen notwendig sein, setzen Sie die Mauswahl durch Mausklick auf das Eingabesymbol (Bleistift) fort. Abgeschlossen wird die Passpunktwahl durch rechten Mausklick. Sie kann jederzeit forgesetzt werden durch Anwahl des Schalters Hinzufügen.

KafPlot speichert sämtliche Optionen zum Bild in einer zum Bild gehörigen Properties-Datei. Es werden die aktuellen Transformationsparameter und Filtereinstellungen gespeichert. Ebenfalls gespeichert werden die Passpunkte mit ihrer digitalisierten Bildkoordinate. Soweit Passpunkte angegeben sind, werden die Transformationsparameter aus den Passpunkten bei jedem Programmstart und nach jedem Daten-Nachladen neu erzeugt. Die Bildeinpassung passiert also immer aufgrund der aktuell von Kafka berechneten Passpunktkoordinaten.

Bei speicherintensiven Bildern ist es oft sinnvoll, dieses nicht vollständig anzuzeigen, sondern nur im aktuell bearbeiteten Bereich. Mit dem Schalter Ausschnitt wählen kann ein anzuzeigender Bildausschnitt gewählt werden. Da die Bild-Transformation auf den aktuellen Ausschnitt damit weniger umfangreich ist, ist der Bildaufbau (bei jedem Zoom) wesentlich kürzer.
Nach Löschen des Ausschnitts wird wieder das gesamte Bild angezeigt.

Handhabung der Bilder in der Grafik

Mit dem Werkzeug Markieren können in der Grafik einzelne Bilder angewählt werden. Wird ein Bild durch Doppelklick markiert, öffnet sich ein Dialog , in dem die wichtigsten Daten zu dem Bild angezeigt werden. Wird mit der rechten Maustaste auf ein Bild geklickt, öffnet sich ein Popup-Menü. Mit Hilfe dieses Menüs kann das Bild ein- oder ausgeblendet oder auch aus der Grafik entfernt werden.

Bedingungen generieren

Die KafPlot-Plus-Version enthält ein Modul zur automatischen Generierung von Bedingungen, zu finden unter Extras > Bedingungen erzeugen. Grundlage ist eine vorhandene Objektstruktur (Flurstücke, Gebäude), die in der Regel über die Geograf-Schnittstelle bereitgetellt wird. Die Informationen über Linienverbindungen werden benötigt, um Geraden-, Parallelen oder Rechtwinkelbedingungen zu finden.

Die mit diesem Modul erzeugten Bedingungen werden in der Liste Homogenisierung unter einem Blatt gespeichert. Der Name des Blattes kann in dem obersten Textfeld vorgegeben werden.

Standardmäßig werden alle Linien im Projekt nach Bedingungen untersucht, mit dem Schalter "nur für sichtbare Linien" kann die Erzeugung auf die sichtbar geschalteten Linien eingeschränkt werden. Die Darstellung der Objekte und der dazugehörigen Linien wird mit dem Dialog Ansicht > Optionen > Flächen gesteuert. Hier können die Listen Flurstücke, Gebäude oder Topographie insgesamt ein- bzw. ausgeschalten werden. Es kann aber auch die Sichtbarkeit einzelner Objekte über eine Auswahlliste eingeschränkt werden.

Mit der Punktauswahl können die bei der Bedingungsgenerierung zu untersuchenden Punkte eingeschränkt werden.
Soweit alle Punkte des Projektes aus derselben Quelle stammen oder sie die gleiche Lagegenauigkeit besitzen, kann die Bedingungsgenerierung Alle Punkte benutzen. Wenn die Bedingungsgenerierung lokal eingegrenzt werden soll, kann eine Punktmenge erzeugt werden. Mit der Auswahl "Menge" werden dann nur diese Punkte untersucht.
In der Regel wird sich die Bedingungsgenerierung auf ein Transformations- bzw. Digitalisiersystem beziehen, da bei der Fehlerabschätzung immer der Kartenmaßstab und die Kartenqualität beachtet werden muß. Bei der Auswahl "Transformation" kann ein Transformationssystem ausgewählt werden. Alle darin enthaltenen Punkte werden in die Suche einbezogen.

Mit den Parametern kann die Generierung der Bedingungen gesteuert werden. Eine Bedingung wird nur erzeugt, wenn gleichzeitig die Werte für Punktlagefehler und Winkelabweichung eingehalten werden. Der Wert Punktlagefehler (LF) hat folgende Bedeutung:
Geradenbedingung:Der Punkt in der Mitte darf nicht mehr als LF aus der geraden Verbindung zwischen Anfangs- und Endpunkt abweichen.
Rechter Winkel: Der aufzuwinkelnde Punkt darf nicht mehr als LF aus dem Rechten Winkel abweichen
Parallele: Die Abstände der Punkte zur Bezugsgeraden dürfen nicht mehr als LF voneinander abweichen

Der Wert Winkelabweichung (WF) wird wie folgt bei der Bedingungssuche interpretiert:
Geradenbedingung:Die größte Winkelabweichung aus der Geraden darf nicht mehr als WF betragen.
Rechter Winkel: Der Winkel zwischen den drei Punkten muss ein Wert zwischen 100-WF und 100+WF besitzen.
Parallele: Die Richtungswinkel der beiden Geraden dürfen nicht mehr als WF voneinander abweichen.

Die Generierung von Bedingungen macht nur Sinn, wenn Neupunkte beteiligt sind, es sollen ja die Koordinaten der digitalisierten Punkte verbessert werden. Daher werden Bedingungen, an denen nur feste Punkte beteiligt sind, von KafPlot nicht erzeugt.

Bei der Bedingungsgenerierung unterscheidet der Algoritmus zwischen Flurstücken und Gebäuden. Für die an den Umringen von Flurstücken beteiligten Punkte werden standardmäßig nur Geradenbedingungen erzeugt. Rechte Winkel in Flurstücks- oder Nutzungsartengrenzen sind relativ selten, ein entsprechender Algoritmus würde aber unzählige Grenzen finden, die nahe dem rechten Winkel aufeinander treffen. Eine Ausgleichung würde hier nicht zum gewünschten Ziel führen.
Bei den Gebäuden werden zusätzlich zu den Fluchten auch die Rechten Winkel erzeugt, sie haben hier den Hauptanteil an der Geometrieverbesserung der enthaltenen Punkte.
Häufig zu finden sind Parallelenbedingungen in den Flurstücksgeometrien. Schmale Wege, Straßen, Bahnen und Fließgewässer sind fast immer parallel. Schon kleine Abweichungen beleidigen hier das Auge des Betrachters, daher sollten diese Bedingungen immer in die Ausgleichung einbezogen werden.
In dem Dialog kann die Erzeugung von Parallelen eingeschalten werden, dabei stehen verschiedene Möglichkeiten zur Auswahl:
frei: Es werden alle Parallelen gefunden, deren Abstand kleiner als im Feld "max. Abstand" angegeben ist. Bei Flurstücken beschränkt sich die Suche auf Flächen mit den Nutzungsarten: Wege, Straßen, Bahngelände, ungenutze oder Verkehrsbegleitfläche und Gewässer.
Dieses Verfahren ist bei Gebäuden anzuwenden und bei Fluren, bei denen die Breiten der Wege und Gewässer nicht runde Maße besitzen.
Meter:Die gefundenen Parallelen erhalten eine Abstandsbedingung, soweit sich die vorgefundenen Abstände innerhalb der mit der Punktlagegenauigkeit gesetzten Schranken befinden. Die Maße werden dabei auf das im Feld "Rundung" angegebene Maß gerundet. Bei Flurstücken werden nur Abstandsmaße erzeugt für die Nutzungsarten: Wege und Gräben.
Dieses Verfahren kann in Gebieten angewendet werden, in denen Grundstücke nach Metern abgesteckt wurden, zB. durch Flurbereinigung.
Ruten:Die gefundenen Parallelen erhalten Rutenmaße als Abstandsbedingungen. Verfahren wird dabei wie bei der "Meter"-Auswahl.
Dieses Verfahren kann in Gebieten angewendet werden, in denen Gräben- und Wegegrundstücke in alten Separationsverfahren festgelegt wurden.

Das Erzeugen der Bedingungen kann mehrmals mit veränderten Parametern durchgeführt werden. Erst beim Übernehmen oder beim Bestätigen mit OK werden die Bedingungen in die KafPlot-Grafik übernommen. Nun muß noch mit Datei > Speichern die Kafka-Dat neu geschrieben werden, dann stehen die Bedingungen für ein erneuten Rechenlauf zur Verfügung.

Doppelte Punkte suchen

Unter Extras > Doppelte Punkte suchen steht ein weiteres, insbesondere für größere Projekte nützliches Modul zur Verfügung.

Der Name dieses Moduls benennt schon treffend dessen Hauptfunktion: Das Auffinden und Handhaben (Verschmelzen) von doppelt nummerierten Punkten.

Für die Suche nach doppelten Punkten ist zuerst der Suchradius anzugeben.
Der voreingestellte Raduis von einem Millimeter ist sicher etwas zu vorsichtig gewählt, jedoch sollte dieser nicht zu groß sein, da eine nachfolgende Verschmelzung der Punkte nur mühselig rückgängig gemacht werden kann.
Es ist sinnvoll, den Radius in mehreren nacheinander folgenden Suchen schrittweise zu erhöhen.


Es sind im folgenden nun drei Aktionen möglich, wobei die ersten beiden mehr dem Aufinden der doppelten Punkte dienen, die dritte Aktion deren Verschmelzen:

Wenn die Schalterstellung Menge erzeugen gewählt wird, werden alle im eingestellten Suchradius gefundenen Punkte lediglich in eine Menge ausgegeben.


Wenn die Schalterstellung Fehlermeldung erzeugen gewählt wird, erscheint in der KafPlot-Grafik an den betreffenden Punkten ein Bemerkungsfenster.


Bei der Schalterstellung Punktidentität erzeugen kann definiert werden, welche der doppelten Punkte bei einer Verschmelzung als Sollpunkt erhalten bleiben soll (Sollpunktentscheidung):
Der Schalter Filter ist identisch dem Erzeugen einer Menge.
Mit dem Schalter Mengenpunkte können bereits sich in einer Menge befindende Punkte als Sollpunkte definiert werden.
Der Schalter Punktstatus hält alle Festpunkte (Status 1 und 2) als Sollpunkte an.
Mit dem Schalter amtliche Punkte werden alle amtlichen Punkte als Sollpunkte übernommen.
Mit dem Schalter Schwerpunkt wird der Punkt als Sollpunkt verwendet, der sich am nahesten am Schwerpunkt der Punktwolke befindet. Somit können auch gleichrangige Punkte verschmolzen werden, bei denen egal ist, welcher als führender gespeichert wird.


Die Punktidentität wird zunächst in der Grafik erzeugt. Erst nach dem Speichern der Grafik werden diese in die Auftragsdatei übernommen:

1  34574727270889                                      2 01 0233                                   <PI1=23139>
0  34574727270879                                      2 01 0233                                   <PI1=23135>
0  34574727270980                                      2 01 0233                                   <PI1=23141>
9  34574727270889                                      2 01 0233                                   <PI1=23139>

Hierfür ist es aber notwendig, daß die Istpunkte mit ihren Koordinaten im Punktdatenblock enthalten sind, da KafPlot diese Identitäten beim Nachladen der Grafik ansonsten nicht mehr darstellen kann.

Wird der Schalter endgültig gesetzt, werden die identischen Punkte in der Auftragsdatei nach dem Speichern der Grafik ersetzt, ohne daß die Punktidentität <PI1=23456> in Spalte 100 eingetragen wird. Die Istpunkte werden endgültig aus der Auftragsdatei gelöscht.

Vorsicht! Ist der Schalter endgültig gesetzt, kann nach dem Speichern der Grafik die Verschmelzung nicht mehr rückgängig gemacht werden!

WLDGE-Import

Über die Import-Funktion können ALB-Daten in Form von WLDGE-Dateien importiert und in die Auftragsdatei übernommen werden.

Es ist dabei zu wählen, in welcher Form die ALB-Daten in die Auftragsdatei übernommen werden sollen.

Wird die Schalterstellung neu als ALB gewählt, werden die Flurstücksdaten aus dem ALB nicht in das evtl. bereits vorhandene Flurstück in der Auftragsdatei übernommen. Stattdessen wird eine zusätzliche Zeile C!Alb: eingefügt, welche die Flurstücksdaten aus dem ALB enthält.

   C!Alb:  122621-004-00135/005/000.8.00 F=1160 N=131 S=04103 L=An_der_Biege_5 A=701
   C!Flst: 122621-004-00135/005/000
   

Diese Schalterstellung ist zu wählen, wenn in der Auftragsdatei bereits Flurstücke enthalten sind, diese aber nicht programmintern überschrieben werden sollen.

Sind in der Auftragsdatei noch keine Flurstücke enthalten, so ist die Schalterstellung neu als FLST zu wählen. In diesem Fall werden alle in der WLDGE-Datei enthaltenen Flurstücke mit der Kennung C!Flst: in die Auftragsdatei übernommen.
Diese Einstellung eignet sich um die ALB-Daten schnell in eine Eigentümerliste zu überstellen.

Die Schalterstellung Abgleich ist sicher die am häufigsten verwendete Möglichkeit des ALB-Imports. Hier werden alle in der Auftragsdatei enthaltenen Flurstücke mit den aus der WLDGE-Datei importierten Flurstücken abgeglichen und nach dem Speichern ergänzt.

Ist der Schalter alle Daten gesetzt, wird für bereits in der Auftragsdatei enthaltene Flurstücke der Abgleich durchgeführt. Alle nicht in der Auftragsdatei vorhandenen Flurstücke werden mit der Zeilenkennung C!Alb: übernommen. Ist dieser Schalter nicht gesetzt, so werden nur die bereits vorhandenen Flurstücke abgeglichen.
Die Zuordnung der Nutzungsartenflächen regelt KafPlot über die Stammnummer der Nutzungsart und über die jeweilige Flächengröße des Nutzungsartenabschnitts. Mit der zulässigen Flächendifferenz wird die dabei mögliche Flächenabweichung eingegrenzt. Der voreingestellte Wert besagt, daß die Abweichung 10m2 plus 20% der Flächengröße betragen darf. Ein Nutzungsartenabschnitt mit 100m2 Fläche darf also um 30m2 abweichen, damit das aus dem ALB stammende Objekt korrekt dem in der Auftragsdatei vorhandenen Objekt zugeordnet werden kann. Wird diese zulässige Flächendifferenz überschritten, wird das WLDGE-Flurstück mit der Kennung C!Alb: als zusätzliche Zeile in die Auftragsdatei übernommen.
Ist der Schalter Flurstücksfläche als Sollfläche gesetzt, wird für alle Flürstücke als Berechnungsart die Fläche mit B=Soll übernommen.
Die Übernahme der Nutzungsartenflächen kann ohne Buchflächen (es werden für die Nutzungsarten keine Flächen übernommen), mit Buchflächen (die Flächen aus dem ALB werden übernommen) oder als Sollflächen (die Flächen der Nutzungsarten werden aus dem ALB als Sollflächen übernommen) erfolgen.

Die Schlüssel der Nutzungsarten unterscheiden sich zum Teil in der Auftragsdatei und im ALB um die dritte Ziffer. Oft sind in einer Datenbank nur die Oberklassen, wie z.B. GFW (130) erfasst, in der anderen Datenbank liegen sie spezialisierter vor (zB: 131).
Die Übernahme der Nutzungsartenschlüssel kann mit der Auswahlbox gesteuert werden. Einerseits kann die Spezialisierung nur aus dem ALB oder nur aus der Auftragsdatei erfolgen. Mit der Auswahl immer wird automatisch die speziellere Nutzungsart für das Flustück übernommen. Ist der Schalter auf keine gesetzt, wird bei verschiedenartigen Unterklassen das ALB-Flurstück mit der Kennung C!Alb: als zusätzliche Zeile in die Auftragsdatei übernommen.

Sind im ALB und in der Auftragsdatei Nutzungsarten verschiedener Oberklassen erfasst, wird eine Fehlermeldung ausgegeben. Ebenso wird bei einer größeren Abweichungen der Flurstücksfläche als durch die zulässigen Flächendifferenz vorgegeben eine Fehlermeldungen erzeugt.

Diese Fehlermeldungen können unmittelbar nach dem WLDGE-Import eingesehen werden.

Die Fehler werden des weiteren in einer Protokolldatei gespeichert. Wird diese in Kafplot importiert, erscheinen an den fehlerhaften Flurstücken Bemerkungsfenster mit den Fehlern.

Sind in der WLDGE-Datei Angaben zu Grundbuchblatt und Eigentümer enthalten, so werden auch diese in die Auftragsdatei übernommen. Diese Daten werden in der Liste Bestand gespeichert.

Digitalisierung erzeugen

Unter Extras > Digitalisierung erzeugen steht ein weiteres, insbesondere für größere Projekte nützliches Modul zur Verfügung.

Nach dem Import der ALK-Daten können mit dieser Funktion Digitalisiersysteme erzeugt werden. KafPlot unterscheidet hierbei nach ALK-Daten und ATKIS-Daten, d.h. es werden anhand der OBAK-Schlüssel getrennte Digitalisiersysteme erzeugt.

Nach dem Abspeichern der Grafik übernimmt KafPlot die Digitalisiersysteme in die Auftragsdatei und schreibt diese mit den im Dialog eingegebenen Genauigkeiten in den Block Transformation.

Punktraster erzeugen

Unter Extras > Punktraster erzeugen kann ein Raster aus Punkten erzeugt werden. Diese können z.B. für die Stabilisierung von Homogenisierungen verwendet werden.

Im Dialog ist der Bereich des Rasters, die Rasterweite, sowie die erste zu vergebene Nummer der zu erzeugenden Punkte einzugeben.

Lagegenauigkeitsstufe erzeugen

In der Umnummerierungsliste kann die LGA mit einem Hashzeichen # versehen werden. Die LGA wird dann beim Anzeigen bzw. Schreiben in Dateien aus der erreichten Lagegenauigkeit bestimmt.

In der PlusVersion ist unter Extras ein Dialog "Lagegenauigkeitsstufe erzeugen" eingefügt worden.

Damit kann die Lagegenauigkeitsstufe aus der Lagegenauigkeit erzeugt werden. Die errechneten LGA werden beim Speichern fest in der Umnumerierungsliste vergeben.

Soll für Punkte mit vorhandener LGA diese verbessert werden, so ist diese Möglichkeit zu aktivieren. Hierfür ist die untere Schranke zur Verbesserung anzugeben. Wird z.B. LGA 2 als untere Schranke vorgegeben, werden alle Punkte mit den vorgegebenen LGA 2 oder schlechter verbessert - natürlich nur, wenn sich die aus den Messelementen errechnete LGA verbessert hat.

WMS - Web Map Service

Ein Web Map Service (WMS) ist eine Schnittstelle zum Abrufen von Auszügen aus Grafikdaten über das World Wide Web.

Die Landesvermessung und Geobasisinformation Brandenburg (LGB) hat verschiedene Daten als WMS-Dienst im Internet frei zur Verfügung gestellt.

In der PlusVersion von KafPlot können diese Daten aus dem Internet abgerufen und als Bitmap eingeblendet werden.

WMS laden

Unter Extras ist der Dialog "WMS laden" zu finden.

In der kafplot.propertis sind einige WMS-Server voreingestellt. Diese können in der ersten Zeile ausgewählt werden. Für einen neuen Server ist die Adresse in der zweiten Zeile einzutragen.

Die WMS-Daten werden als Bitmap dargestellt. Nach dem Laden der Daten kann über Optionen ein weiterer Dialog geöffnet werden. Hier können Einstellungen zur Darstellung der Bitmap gemacht werden. Ebenso kann ausgewählt werden, welche Daten (z.B. welche Folien der ALK) geladen werden.

Die Handhabung (Ausblenden, Änderung der Einstellungen, Löschen) der geladenen WMS-Daten erfolgt nach gewohnter Weise der Handhabung von Bitmaps.

Der Zugriff auf einen WMS-Server dauert einige Zeit, insbesondere wenn ein Proxy-Server zwischen geschalten ist. Der Bildauschnitt wird bei jedem veränderten Zoom neu aus dem Internet abgerufen, da hierbei jeweils eine neue Bitmap vom WMS-Server generiert und zum KafPlot-Client geschickt wird.

Bitte beachten Sie die rechtlichen Bedingungen, unter denen die jeweiligen Dienste im Internet zur Verfügung gestellt werden.

WMS erzeugen

Eine weitere Möglichkeit in der PlusVersion ist der Austausch von KafPlot-Daten in Form von WMS-Daten mit anderen KafPlot-Aufträgen oder WMS-fähigen Programmen.

Hierfür ist unter Extras der Dialog "WMS erzeugen" zu finden.

Mit dem Schalter Adresse kopieren wird die Portadresse in die Zwischenablage kopiert und kann in anderen Anwendungen eingefügt werden.

KafPlotService

Mit diesem Tool besteht die Möglichkeit, mehrere KafPlotSessions miteinander zu verbinden. Eine geöffnete Session läuft als Server und gibt die Koordinaten, den Rotationswinkel, die Zoomstufe und die Ellipsengröße an alle verbundenen Sessions weiter. Damit kann sich ein Auftrag (oder auch benachbarte Projekte) mit veränderten Darstellungsoptionen im mehreren Sessions angeschaut werden.

Service erzeugen

Unter Extras ist der Dialog "KafPlotService erzeugen" zu finden.

In der führenden Session ist KafPlotService erzeugen zu starten.

Alle anderen Sessions können danach mit KafPlotService verbinden an die führende Session angemeldet werden.

Für diese Lösung wurden MultiCastSockets verwendet mit der Nachrichten von einem Server an mehrere Clients verteilt werden können. Nicht alle Nertwerke unterstützen diese Lösung.

Punkte umnummerieren

Für die massenhafte Umnummerierung von Punkten ist dieses Tool gedacht.

Unter Extras ist der Dialog "Punkte umnummerieren" zu finden.

Mit den Schaltern Nummer reduzieren bzw. Nummer erweitern können Punktnummern gekürzt oder erweitert werden und deren zu erzeugende Länge eingestellt werden

Für eine Umnummerierung ist die Auswahl neue Nummer gedacht. Die Startnummer für die Umnummerierung ist vorzugeben sowie, wenn gewünscht, ein Punktnummernzuschlag, welcher der Punktnummer vorgesetzt wird.

Wird der Schalter Gmk+Flur+ gesetzt, erhalten die Punkte einen 9stelligen Zuschlag aus Gemarkungsnummer (6stellig) und Flur (3stellig). Auch hier ist die Startnummer für die Umnummerierung vorzugeben. Ist der Schalter mit Vorgabe gesetzt, werden die in der gemarkungen.pnr.properties vorgegebenen Startnummern für die Umnummerierung verwendet.

Mit dem Schalter aus Umnumliste werden die Punkte gemäß der vorgegebenen Nummerierungsbereiche aus der Auftragsdatei umnummeriert. Hierbei besteht die Möglichkeit, das PNR-Zuschlag auszuwählen.

Das Ergebnis wird als Umnummerierung in die Umnummerierungsliste geschrieben. Sollen die Punktnummern endgültig übernommen werden, ist dieser Schalter zu setzen. Die umnummerierten Punktnummern werden dann in der Auftragsdatei überschrieben.

Mit dem Schalter amtliche Punkte ausschließen werden ebendiese nicht in die Umnummerierung eingeschlossen.

Selbstverständlich kann die Umnummerierung auch durch eine zuvor vereinbarte Menge erfolgen.

Katasternachweis umgewichten

Unter Extras ist der Dialog "Katasternachweis umgewichten" zu finden.

Hiermit werden die Messungselemente des Katasternachweises umgewichtet.

Nur die Messungen des Bestimmungsrisses behalten ihr ursprüngliches Gewicht. Alle Folgemessungen werden herabgewichtet. Bestimmend ist hierbei die Reihenfolge der Eingabe in der Auftragsdatei. Ziel soll es sein, dass die in der Regel korrelierten Folgemessungen ihren Einfluss auf die Bestimmung der Punktgenauigkeit verlieren. Mit der Datenprüfung können somit Abweichungen gegenüber den Ursprungsmaßen aufgedeckt werden.

 

 KafPlot-Support (Info, Fragen, Anregungen)


© 1999 JS